Could not find com.github.textileio:android-upload-service:3.5.5

I am trying to install the React Native Textile library by following the instructions below:

  • npm install @textile/react-native-sdk --save
  • link the framework
  • update android gradle ( maven { url “https://dl.bintray.com/textile/maven” } )
  • installing the dependencies ( react-native-background-fetch and react-native-background-timer)

After running ‘react-native run-android’ command I have the following error:

Could not determine the dependencies of task ‘:app:preDebugBuild’.

Could not resolve all task dependencies for configuration ‘:app:debugRuntimeClasspath’.
Could not find com.github.textileio:android-upload-service:3.5.5.
Searched in the following locations:
- file:/C:/Users/Ardelean/.m2/repository/com/github/textileio/android-upload service/3.5.5/android-upload-service-3.5.5.pom
- file:/C:/Users/Ardelean/.m2/repository/com/github/textileio/android-upload service/3.5.5/android-upload-service-3.5.5.jar
- file:/D:/ReactNative/MyTSProject/node_modules/react-native/android/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.pom
- file:/D:/ReactNative/MyTSProject/node_modules/react-native/android/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.jar
- file:/D:/ReactNative/MyTSProject/node_modules/jsc-android/dist/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.pom
- file:/D:/ReactNative/MyTSProject/node_modules/jsc-android/dist/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.jar
- https://dl.bintray.com/textile/maven/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.pom
- https://dl.bintray.com/textile/maven/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.jar
- https://dl.google.com/dl/android/maven2/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.pom
- https://dl.google.com/dl/android/maven2/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.jar
- https://jcenter.bintray.com/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.pom
- https://jcenter.bintray.com/com/github/textileio/android-upload-service/3.5.5/android-upload-service-3.5.5.jar
Required by:
project :app > project :@textile_react-native-sdk > io.textile:textile:2.1.2

Can anyone tell me what’s wrong?

That library has been deprecated! Take a look at js-threads for the latest react-native layer.